mod_auth_pam

Introduction

This module makes Prosody authenticate users against PAM (Linux Pluggable Authentication Modules)

Dependencies

The module depends on lua-pam and LuaPosix.

Setup

Create a /etc/pam.d/xmpp with something like this:

auth    [success=1 default=ignore]  pam_unix.so obscure sha512 nodelay
auth    requisite           pam_deny.so
auth    required            pam_permit.so

And switch authentication provider in the Prosody config:

authentication = "pam"

Compatibility

Compatible with 0.9 and up


Installation

With the plugin installer in Prosody 0.12 you can use:

sudo prosodyctl install https://modules.prosody.im/rocks/mod_auth_pam-2-1.src.rock

For other see the documentation for installing 3rd party modules