mod_csi_simple_compat

About

This module allows using the mod_csi_simple setting csi_important_payloads (added in trunk/0.12) in Prosody 0.11.x.

Config

modules_enabled = {
    -- other modules etc
    "csi_simple",
    "csi_simple_compat",
}

csi_important_payloads = {
    -- Anything in this namespace:
    "{urn:example:important-namespace}",
    -- Specific element name and namespace:
    "{urn:example:xmpp:priority}super-important",
}

Example

csi_important_payloads = {
    -- XEP-0353: Jingle Message Initiation
    "{urn:xmpp:jingle-message:0}",
}

Installation

With the plugin installer in Prosody 0.12 you can use:

sudo prosodyctl install --server=https://modules.prosody.im/rocks/ mod_csi_simple_compat

For other see the documentation for installing 3rd party modules